See our current list of supported devices here. Don't worry if your phone isn't listed here. As long as it meets the requirements listed below you should have no issues pairing with the Band.


Our devices require BLE (Bluetooth low energy a.k.a Bluetooth 4.0) to connect. BLE is only available in certain operating systems and phones, and generally was not implemented in Android phones before Android 4.3. The iPhone 4 does not include BLE capabilities. (Android users: the following app will allow you to confirm if your phone/tablet possesses BLE - https://play.google.com/store/apps/details?id=com.magicalboy.btd&hl=en)

 

iOS requires 8 and higher (iPhone 4 excluded)

Android requires 4.4 and higher 

 

Please note, our Band does not sync with a computer. You must have a smartphone/tablet to use the Band.